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Abstract 
 

  

These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) Trunking Service on an enterprise solution consisting of Avaya IP Office 11.1 to support 

WorldNet Telecommunications SIP Trunking Service. 

 

The test was performed to verify SIP trunk features including basic calls, call forward (all 

calls, busy, no answer), call transfer (blind and consultative), conference, and voice mail. The 

calls were placed to and from the public switched telephone network (PSTN) with various 

Avaya endpoints. 

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 

 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions.  Testing was conducted via the DevConnect 

Program. 
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1. Introduction 
These Application Notes describe the steps necessary for configuring Session Initiation Protocol 

(SIP) Trunking Service between WorldNet Telecommunications and an Avaya SIP-enabled 

enterprise solution. 

 

In the configuration used during the testing, the Avaya SIP-enabled enterprise solution consists 

of an Avaya IP Office Server Edition, two Avaya IP Office 500 V2 as expansion systems, 

running software release 11.1 (hereafter referred to as IP Office) and various Avaya endpoints, 

listed in Section 4. 

 

The WorldNet Telecommunications SIP Trunking Service referenced within these Application 

Notes is designed for business customers. Customers using this service with the IP Office 

solution are able to place and receive PSTN calls via a broadband wide area network (WAN) 

connection using the SIP protocol. This converged network solution is an alternative to 

traditional PSTN trunks such as analog and/or ISDN-PRI trunks. This approach generally results 

in lower cost for the enterprise. 

 

The terms “service provider”, “WorldNet Telecommunications” or “WorldNet” will be used 

interchangeably throughout these Application Notes. 

2. General Test Approach and Test Results  
The general test approach was to connect a simulated enterprise site to the WorldNet 

Telecommunications network via the public Internet, as depicted in Figure 1, and exercise the 

features and functionalities listed in Section 2.1. 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent 

to the interoperability of the tested products and their functionalities. DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in this DevConnect 

Application Note included the enablement of supported encryption capabilities in the Avaya 

products. Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

 

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor. Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products. 

 

User Data Protocol (UDP) and Real-time Transport Protocol (RTP) were used between the 

simulated enterprise site and the WorldNet Telecommunications network (public network side), 
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Transport Layer Security (TLS) and Secure Real-Time Transport Protocol (SRTP) were used 

inside of the enterprise (private network side). 

2.1. Interoperability Compliance Testing 

To verify SIP trunk interoperability the following features and functionalities were exercised 

during the interoperability compliance test: 

• SIP Trunk Registration (Dynamic Authentication). 

• Response to SIP OPTIONS queries. 

• Incoming PSTN calls to various Avaya endpoints, including SIP, H.323, Digital and 

Analog telephones at the enterprise. All incoming calls from the PSTN were routed to the 

enterprise across the SIP trunk from the service provider’s network. 

• Outgoing PSTN calls from Avaya endpoints, including SIP and H.323, Digital and 

Analog telephones at the enterprise. All outgoing calls to the PSTN were routed from the 

enterprise across the SIP trunk to the service provider’s network. 

• Incoming and outgoing PSTN calls to/from Avaya Workplace Client for Windows (SIP). 

• Dialing plans including local calls, international calls, outbound toll-free, etc. 

• Caller ID presentation. 

• Proper disconnect when the caller abandons the call before the call is answered. 

• Proper disconnect via normal call termination by the caller or the called parties. 

• Proper disconnect by the network for calls that are not answered (with coverage to 

voicemail off). 

• Proper response to busy endpoints. 

• Proper response/error treatment when dialing invalid PSTN numbers.  

• Proper codec negotiation and two-way speech-path. Testing was performed with codecs: 

G.722 64K and G.711MU, with G.722 64K being the preferred codec. 

• Proper response to no matching codecs. 

• Proper early media transmissions. 

• Voicemail and DTMF tone support using RFC 2833 (leaving and retrieving voice mail 

messages, etc.). 

• Call Hold/Resume (long and short duration). 

• Call Forward (unconditional, busy, no answer).  

• Blind Call Transfers. 

• Consultative Call Transfers. 

• Station Conference. 

• Mobility twinning of incoming calls to mobile phones. 

• G.711 pass-through fax. 
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Items not supported or not tested included the following: 

• Inbound toll-free calls, 911 calls (emergency), “0” calls (Operator), 0+10 digits calls 

(Operator Assisted) were not tested. 

• T.38 fax – WorldNet doesn’t support T.38 fax, G.711 pass-through is the preferred fax 

method for WorldNet. G.711 pass-through fax was tested successfully. 

2.2.  Test Results 

Interoperability testing of WorldNet Telecommunications SIP Trunking Service was completed 

with successful results for all test cases with the exception of the observations/limitations 

described below. 

• Call transfer to the PSTN using the SIP REFER method – Calls from the PSTN to the 

enterprise that were transferred back to the PSTN network using the SIP REFER method 

did not work properly. Due to this reason, REFER was left disabled in Avaya IP Office 

for the tests (refer to Sections 5.4.2). 

• One-Way audio during outbound calls from Avaya Workplace Client for Windows 

softphone (SIP) to the PSTN – One-way audio was observed on calls originated from 

Avaya Workplace Client for Windows softphone (SIP) to the PSTN, there was no audio 

from Workplace to the PSTN, good audio was observed from the PSTN to Workplace. 

The issue only occurs when Media Security, under System → VoIP → VoIP Security 

tab, is enabled in IP Office (e.g., set to “Preferred”). When set to “Disabled” there were 

no issues, audio was good in both directions. This issue is under investigation by Avaya. 

As a temporary work around, if TLS/SRTP is being use in IP Office, set  Media 

Security, under System → VoIP → VoIP Security tab in IP Office, to Disabled (refer 

to Section 5.2.3.2). 
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2.3. Support 

For support on WorldNet Telecommunications SIP Trunking Service visit the corporate Web 

page at: https://www.worldnetpr.com/en/voice-service/ 

 

Avaya customers may obtain documentation and support for Avaya products by visiting 

http://support.avaya.com. Alternatively, in the United States, (866) GO-AVAYA (866-462-8292) 

provides access to overall sales and service support menus. 

3. Reference Configuration 
Figure 1 illustrates the test configuration used for the DevConnect compliance testing. The test 

configuration simulates an enterprise site with an Avaya SIP-enabled enterprise solution 

connected to the WorldNet Telecommunications SIP Trunking Service through the public 

Internet. 

 

The Avaya components used to create the simulated enterprise customer site includes: 

• IP Office Server Edition running in VMware environment. 

− Avaya IP Office Voicemail Pro. 

• Two Avaya IP Office 500 V2 as expansion systems. 

• Avaya J179 IP Deskphones (H.323). 

• Avaya 1100 Series IP Deskphones (SIP). 

• Avaya J129 IP Deskphones (SIP). 

• Avaya 1400 Series Digital Deskphones. 

• Analog Deskphones. 

• Avaya Workplace Client for Windows (SIP). 

 

Avaya IP Office provides the voice communications services for the enterprise. In the reference 

configuration, Avaya IP Office runs on the Avaya IP Office Server Edition platform. Note that 

this solution is extensible to deployments using the standalone IP500 V2 platform as well. 

 

In the sample configuration, the Primary server runs the Avaya IP Office Server Edition Linux 

software. Avaya Voicemail Pro runs as a service on the Primary Server. The LAN1 port of the 

Primary Server is connected to the enterprise LAN. The LAN2 port was used to connect to the 

public network. 

 

The Expansion Systems (IP500 V2) were used for the support of digital, analog and additional IP 

stations. The Avaya IP Office 500 V2 is equipped with analog and digital extension expansion 

modules, as well as a VCM64 (Voice Compression Module). The LAN1 ports of the Avaya IP 

Office IP500 V2 systems are connected to the enterprise LAN, the LAN2 ports were not used.  

 

IP endpoints at the enterprise included Avaya 1100 Series IP Deskphones (with SIP firmware), 

Avaya J100 Series IP Deskphones (with SIP and H.323 firmware), Avaya Workplace Client for 

Windows (SIP), Avaya Digital and Analog Deskphones. IP endpoints were registered to the 

Primary Server; non-IP endpoints (analog and digital) were registered to the Expansion Systems. 

The site also has a Windows PC running Avaya IP Office Manager to configure and administer 

https://www.worldnetpr.com/en/voice-service/
http://support.avaya.com/
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the system. Mobile Twinning is configured for some of the IP Office users so that calls to these 

user’s extensions will also ring and can be answered at the configured mobile phones.  

 

For inbound calls, the calls flowed from the WorldNet Telecommunications network to IP 

Office.  

 

Outbound calls to the PSTN were first processed by IP Office. Once IP Office selected the 

proper SIP trunk, the call was routed to the WorldNet Telecommunications network. 

 

For the compliance test, users dialed a short code of 9 + N digits to make calls across the SIP 

trunk to WorldNet Telecommunications network. The short code 9 was stripped off by Avaya IP 

Office, but the remaining N digits were sent unaltered to the WorldNet Telecommunications 

network. 

 

In an actual customer configuration, the enterprise site may include additional network 

components between the service provider and the IP Office system, such as a session border 

controller or data firewall. A complete discussion of the configuration of these devices is beyond 

the scope of these Application Notes. However, it should be noted that all SIP and RTP traffic 

between the service provider and the IP Office system must be allowed to pass through these 

devices. 

 

For confidentiality and privacy purposes, public IP addresses and routable DID numbers used 

during the compliance testing were masked. 
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Figure 1: Avaya DevConnect lab Configuration 
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4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Equipment/Software Release/Version 

Avaya 

Avaya IP Office Server Edition (Primary Server) 

• Avaya IP Office Voicemail Pro 

11.1.2.4.0 Build 18 

11.1.2.4.0 Build 2 

Avaya IP Office IP500 V2 (Expansion Systems) 11.1.2.4.0 Build 18 

Avaya IP Office Manager 11.1.2.4.0 Build 18 

Avaya J179 IP Telephone (H.323) Version 6.8.5.4.10 

Avaya 1140E IP Deskphones (SIP) SIP1140e Ver. 04.04.23.00 

Avaya J129 IP Deskphones (SIP) Version 4.0.10.3.2 

Avaya 1408 Digital Telephone 48.02 

Avaya Workplace Client for Windows (SIP). 3.34.1.10 

Analog Telephone --- 

WorldNet Telecommunications 

Metaswitch CFS: V9.3.20 

Oracle SBC Acme Packet 4600 SCZ8.1.0 GA  

(Build 33) 

 

Note: Compliance Testing is applicable when the tested solution is deployed with a standalone 

IP Office 500 V2 and also when deployed with all configurations of IP Office Server Edition. IP 

Office Server Edition requires an Expansion IP Office 500 V2 to support analog or digital 

endpoints. 
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5. Avaya IP Office Primary Server Configuration 
Avaya IP Office is configured through the Avaya IP Office Manager application. From the PC 

running the IP Office Manager application, select Start → Programs → IP Office → Manager 

to launch the Manager application. Log in using the appropriate credentials. 
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On Server Edition systems, the Solution View screen will appear, similar to the one shown 

below. All the Avaya IP Office configurable components are shown in the left pane, known as 

the Navigation Pane. Clicking the “plus” sign next to the Primary server system name, e.g., 

IPOSE-Primary, on the navigation pane will expand the menu on this server. 
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In the screens presented in the following sections, the View menu was configured to show the 

Navigation pane on the left side and the Details pane on the right side. These panes will be 

referenced throughout the rest of this document.  

 

Standard feature configurations that are not directly related to the interfacing with the service 

provider are assumed to be already in place, and they are not part of these Application Notes. 

5.1. Licensing  

The configuration and features described in these Application Notes require the IP Office system 

to be licensed appropriately. If a desired feature is not enabled or there is insufficient capacity, 

contact an authorized Avaya sales representative. 

 

In the reference configuration, IPOSE-Primary was used as the system name of the Primary 

Server, IP500V2-One and IP500V2-Two were used as the system name for the two Expansion 

Systems. All navigation described in the following sections (e.g., License) appears as submenus 

underneath the system name in the Navigation Pane.  

 

Navigate to License in the Navigation Pane. In the Details Pane verify that the License Status 

for SIP Trunk Channels is Valid and that the number of Instances is sufficient to support the 

number of channels provisioned for the SIP trunk. 
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5.2. System Settings  

Configure the necessary system settings. In an Avaya IP Office, the LAN2 tab settings 

correspond to the Avaya IP Office WAN port (public network side) and the LAN1 tab settings 

correspond to the LAN port (private network side). 

5.2.1. System – LAN2 Tab 

In the sample configuration, IPOSE-Primary was used as the system name, the LAN2 port is 

used for the SIP trunk connection to WorldNet Telecommunications. 

  

To view or configure the LAN2 port IP address and subnet mask, select the LAN2→ LAN 

Settings tab, and enter the information as needed, according to the customer network 

requirements: 

• Set the IP Address field to the LAN IP address, e.g., 10.10.80.55. 

• Set the IP Mask field to the subnet mask of the enterprise private network, e.g., 

255.255.255.128. 

• All other parameters should be set according to customer requirements. 

• Click OK to commit (not shown). 
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5.2.1.1 LAN2 VoIP Tab 

The VoIP tab as shown in the screenshot below was configured with following settings: 

• Select the LAN2 → VoIP tab in the Details Pane. Check the SIP Trunks Enable box to 

allow the configuration of SIP trunks. Since no SIP endpoints are to register on this 

interface (SIP endpoints register to the LAN1), leave the SIP Registrar Enable box 

unchecked. 
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Scroll down the page: 

• Verify the RTP Port Number Range. Based on this setting, Avaya IP Office will 

request RTP media in the configurable range for calls using LAN2. The Minimum and 

Maximum port numbers were kept at their default values in the reference configuration. 

• In the Keepalives section, set the Scope to RTP-RTCP. Set the Periodic timeout to 30 

and the Initial keepalives parameter to Enabled. This is done to prevent possible issues 

with network firewalls closing idle RTP channels.  

• In the DiffServ Settings section, IP Office can be configured to mark the Differentiated 

Services Code Point (DSCP) in the IP Header with specific values to support Quality of 

Services (QoS) policies for both signaling and media. The DSCP field is the value used 

for media, while the SIG DSCP is the value used for signaling. These settings should be 

set according to the customer’s QoS policies in place. The default values used during the 

compliance test are shown. 

• Click OK to commit. 
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Note: In the compliance test, the LAN1 interface was used to connect the Avaya IP Office to the 

enterprise site IP network (private network). The LAN1 interface configuration is not directly 

relevant to the interface with the WorldNet Telecommunications SIP Trunking Service, and 

therefore is not described in these Application Notes. 

5.2.1.2 LAN2 Network Topology tab 

The Network Topology tab as shown in the screenshot below was configured with following 

settings: 

• The Firewall/NAT Type was set to Open Internet in the reference configuration.  

• The Binding Refresh Time (sec) was set to 60 seconds. This is used to determine the 

frequency at which Avaya IP Office will send SIP OPTIONS messages, to periodically 

check the status of the SIP lines configured on this interface.  

• The Public IP Address was set to the public IP address of LAN2 (e.g., 10.10.80.55) and 

Public Port and the standard UDP, TCP and TLS ports, as shown. 

• Click OK to commit. 
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5.2.2. System - Telephony Tab 

To access the System Telephony settings, navigate to the Telephony → Telephony tab in the 

Details pane, configure the following parameters:  

• Choose the Companding Law typical for the enterprise location; U-Law was used for 

the compliance test. 

• Uncheck the Inhibit Off-Switch Forward/Transfer box to allow call forwarding and 

call transfer to the PSTN. If for security reasons incoming calls should not be allowed to 

transfer back to the PSTN then leave this setting checked.  

• All other parameters should be set to default or according to customer requirements.  

• Click OK to commit. 
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5.2.3. System - VoIP Tab 

Navigate to the VoIP tab in the Details pane to view or change the system codecs and VoIP 

security settings. 

5.2.3.1 VoIP - VoIP Tab 

Select the VoIP → VoIP tab, configure the following parameters: 

• The RFC2833 Default Payload field allows for the manual configuration of the payload 

type used on SIP calls that are initiated by the IP Office. The default value 101 was used. 

• For codec selection, select the codecs and codec order of preference on the right, under 

the Selected column. The Default Codec Selection area enables the codec preference 

order to be configured on a system-wide basis. The buttons between the two lists can be 

used to move codecs between the Unused and Selected lists, and to change the order of 

the codecs in the Selected codecs list. By default, all IP lines and phones (SIP and H.323) 

will use the system default codec selection shown here, unless configured otherwise for a 

specific line or extension. The example below shows the codecs used for IP phones (SIP 

and H.323). 

• Click OK to commit. 

 

 
 

Note: The codec selections defined under this section (VoIP – VoIP tab) are the codecs selected 

for the IP phones/extensions. The codec selections defined under Section 5.4.6 (SIP Line – VoIP 

tab) are the codecs selected for the SIP Line (Trunk). 
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5.2.3.2 VoIP – VoIP Security Tab 

Secure Real-Time Transport Protocol (SRTP) refers to the application of additional encryption 

and or authentication for VoIP calls (SIP and H.323). SRTP can be applied between telephones, 

between ends of an IP trunk or in various other combinations. 

 

Configuring the use of SRTP at the system level is done on the VoIP Security tab using the 

Media Security setting. The options are: 

• Disabled (default). 

• Preferred. 

• Enforced. 

 

When enabling SRTP on the system, the recommended setting is Preferred. In this scenario, IP 

Office uses SRTP if supported by the far-end, otherwise uses RTP. If the Enforced setting is 

used, and SRTP is not supported by the far-end, the call is not established. 

 

To configure the use of SRTP, select the VoIP → VoIP Security tab on the Details pane.  

• Set the Media Security drop-down menu to Preferred to have IP Office attempt use 

encrypted RTP for devices that support it and fall back to RTP for devices that do not 

support encryption.  

• Verify Strict SIPS is not checked. 

• Under Media Security Options, select RTP for the Encryptions and Authentication 

fields.  

• Under Crypto Suites, select SRTP_AES_CM_128_SHA1_80.  

• Click OK to commit. 
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5.3. IP Route 

Create an IP route to specify the IP address of the gateway or router where the IP Office needs to 

send the packets in order to route calls to WorldNet Telecommunications network.  

 

Navigate to IP Route, right-click on IP Route and select New. The values used during the 

compliance test are shown below: 

• Set the IP Address and IP Mask to 0.0.0.0 to make this the default route. 

• Set Gateway IP Address to the IP address of the gateway/router used to route calls to the 

public network, e.g., 10.10.80.1. 

• Set Destination to LAN2 from the pull-down menu. 

• Click OK to commit. 
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5.4. SIP Line  

A SIP line is needed to establish the SIP connection between Avaya IP Office and WorldNet 

Telecommunications. The recommended method for configuring a SIP Line is to use the 

template associated with these Application Notes. The template is an .xml file that can be used 

by IP Office Manager to create a SIP Line. Follow the steps in Sections 5.4.1 to create the SIP 

Line from the template. 

 

Some items relevant to a specific customer environment are not included in the template or may 

need to be updated after the SIP Line is created. Examples include the following: 

• IP addresses 

• SIP Credentials (if applicable) 

• SIP URI entries 

 

Therefore, it is important that the SIP Line configuration be reviewed and updated, if necessary, 

after the SIP Line is created via the template. The resulting SIP Line data can be verified against 

the manual configuration shown in Section 5.4.2 to 5.4.7. 

 

Alternatively, a SIP Line can be created manually. To do so, right-click on Line in the 

Navigation pane and select New → SIP Line. Then, follow the steps outlined in Sections 5.4.2 

to 5.4.7. 

5.4.1. Creating a SIP Trunk from an XML Template 

DevConnect generated SIP Line templates are always exported in an XML format. These XML 

templates do not include sensitive customer specific information and are therefore suitable for 

distribution. The XML format templates can be used to create SIP trunks on both IP Office 

Standard Edition (500 V2) and IP Office Server Edition systems. Alternatively, binary templates 

may be generated. However, binary templates include all the configuration parameters of the 

Trunk, including sensitive customer specific information. Therefore, binary templates should 

only be used for cloning trunks within a specific customer’s environment. 

 

Copy a previously created template file to a location (e.g., \Temp) on the same computer where 

IP Office Manager is installed.  
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To create the SIP Trunk from the template, from the Primary server, right-click on Line in the 

Navigation Pane, then navigate to New → New from Template→Open from file. 
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Navigate to the directory on the local machine where the template was copied and select the 

template. 

 

 
 

After the import is complete, a final import status pop-up window will open stating success or 

failure. Click OK. 
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The newly created SIP Line will appear in the Navigation pane (e.g., SIP Line 17). 

 

 
 

It is important that the SIP Line configuration be reviewed and updated, if necessary, after the 

SIP Line is created via the template. The resulting SIP Line data can be verified against the 

manual configuration shown in Sections 5.4.2 to 5.4.7. 
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5.4.2. SIP Line – SIP Line Tab 

On the SIP Line tab in the Details pane, configure or verify the parameters as shown below: 

• Leave the ITSP Domain Name blank. Note that if this field is left blank, then IP Office 

inserts the ITSP Proxy Address from the Transport tab as the ITSP Domain in the SIP 

messaging. 

• Under Local Domain Name enter the public IP address assigned to the LAN2 interface 

(Section 5.2.1). 

• Verify that In Service box is checked, the default value. This makes the trunk available 

to incoming and outgoing calls. 

• Verify that Check OOS box is checked, the default value. IP Office will use the SIP 

OPTIONS method to periodically check the SIP Line. 

• Verify that Refresh Method is set to Auto. 

• Verify that Timer (sec) is set to On Demand. 

• Under Redirect and Transfer, set Incoming Supervised REFER and Outgoing 

Supervised REFER to Never (refer to Section 2.2). 

• Click OK to commit. 
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5.4.3. SIP Line - Transport Tab 

Select the Transport tab. Set or verify the parameters as shown below: 

• Set the ITSP Proxy Address to the public IP address (signaling IP address) of 

WorldNet’s SIP Proxy server (192.168.96.97) as shown in Figure 1. This information 

should be provided by WorldNet. 

• Set Layer 4 Protocol to UDP. 

• Set Use Network Topology Info to None (see note below).  

• Set the Send and Listening Ports to 5060. 

• Default values may be used for all other parameters. 

• Click OK to commit. 

 

 
 

Note – For the compliance testing, the Use Network Topology Info field was set to None, 

since no NAT was used in the test configuration. If a NAT is used between Avaya IP Office 

and the other end of the trunk, then the Use Network Topology Info field should be set to the 

LAN interface (LAN1 or LAN2) used by the trunk and the System → LAN1 (or 2) → 

Network Topology tab needs to be configured with the details of the NAT device. 
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5.4.4. SIP Line – SIP Credentials Tab 

Select the SIP Credentials tab, and then click the Add button to add the SIP Trunk registration 

credentials. Set the parameters as show below: 

• For User name, enter the user name credential provided by WorldNet for SIP Trunk 

registration. 

• Leave Authentication Name blank. 

• Leave the Contact blank. 

• For Password and Confirm Password, add the password credential provided by 

WorldNet for SIP Trunk registration. 

• Set Expiry (mins) to a value acceptable to the enterprise. This setting defines how often 

registration with Clearcom is required following any previous registration. For the 

compliance test 60 minutes was used. This value should be chosen in consultation with 

the service provider. 

• Verify that Registration required is checked. 

• Click the OK to commit. 
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5.4.5. SIP Line – Call Details Tab 

Select the Call Details tab, and then click the Add… button (not shown) and the screen shown 

below will appear. To edit an existing entry, click an entry in the list at the top, and click the 

Edit… button. In the example screen below one new entry was added to handle incoming and 

outgoing calls, both. 

• Associate this entry to an outgoing line group using the Outgoing Group field. The 

outgoing line group number is used in defining short codes for routing outbound traffic 

from this line. For the compliance test outgoing group 17 was used. Leave the Incoming 

Group field as 0. 

• Under Credentials, select 1: user123 from the pull-down menu (this field will default to 

the User name used under the SIP Credentials tab in Section 5.4.4). 

• Set Max Sessions to the number of simultaneous SIP calls that are allowed using this SIP 

URI pattern. 

• Check the P Asserted ID and Diversion Header.  

• Set the Local URI, Contact, P Asserted ID and Diversion Header fields to the values 

shown in the screenshot below. 

• Set all remaining fields as shown on the screenshot below.  

• Click OK to Commit. 
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5.4.6. SIP Line - VoIP Tab 

Select the VoIP tab, to set the Voice over Internet Protocol parameters of the SIP Line. Set or 

verify the parameters as shown below: 

• The Codec Selection was configured using the System Default option. The buttons 

allow setting the specific order of preference for the codecs to be used on the SIP Line, as 

shown. WorldNet Telecommunications supports codecs G.722 64K and G.711 ULAW 

64K for audio. 

• Select G.711 for Fax Transport Support (Refer to Section 2.1). 

• Set the DTMF Support field to RFC2833/RFC4733. This directs Avaya IP Office to 

send DTMF tones using RTP events messages as defined in RFC2833. 

• Set the Media Security field to Disabled. 

• Check the Re-invite Supported box.  

• Check the PRACK/100rel Supported box.  

• Default values may be used for all other parameters. 

• Click the OK to commit. 

 

 
 

Note: The codec selections defined under this section are the codecs selected for the SIP Line 

(Trunk). The codec selections defined under Section 5.2.3 are the codecs selected for the IP 

phones/extension (H.323 and SIP). 
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5.4.7. SIP Line – SIP Advanced Tab 

In the Addressing area: 

• Select To Header for Call Routing Method. 

 

In the Identity area: 

• Check the box for Use PAI for Privacy. 

• Default values may be used for all other parameters. 

• Click OK to commit. 
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5.5. IP Office Line – Primary Server 

In IP Office Server Edition systems, IP Office Lines are automatically created on each server 

when a Secondary server or Expansion System is added to the solution. To edit an existing IP 

Office Line, select Line in the Navigation pane, and select the appropriate line to be configured 

in the Group pane. The screen below shows the IP Office Line to the IP500V2-One Expansion 

System. 
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The screen below shows the IP Office Line, VoIP Settings tab:  

• Under Codec Selection verify System Default is selected (default value). 

• Select G.711 for Fax Transport Support (refer to Section 2.1). 

• Under Media Security verify Same as System (Preferred) is selected (default value). 

• On the Advanced Media Security Options check Same As System. 

• Click OK to commit. 

 

 
 

Repeat this process as needed to add additional Secondary server or Expansion Systems to the 

solution. 

 



 
HG; Reviewed: 

SPOC 12/11/2023 

Avaya DevConnect Application Notes 

©2023 Avaya Inc. All Rights Reserved. 

33 of 52 

WorldNet_IPO111 

 

5.6. Incoming Call Route 

Incoming call routes map inbound DID numbers on a specific line to internal extensions, hunt 

groups, short codes, etc., within the IP Office system. To add an incoming call route, right click 

on Incoming Call Route in the Navigation pane and select New (not shown). On the Details 

Pane, under the Standard tab, set the parameters as show below: 

• Set Bearer Capacity to Any Voice.  

• The Line Group ID is set to 17. This matches the Incoming Group field configured in 

the Call Details tab for the SIP Line on Section 5.4.5. 

• On the Incoming Number, enter one of the DID numbers provided by WorldNet 

Telecommunications. 

• Default values may be used for all other parameters. 

• Click OK to commit. 
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Select the Destinations tab. From the Destination drop-down menu, select the IP Office 

extension associated with this DID number. In the reference configuration, the DID number 

7879578057 provided by WorldNet Telecommunications was associated with the Avaya IP 

Office extension 3042. 

 

 
 

Repeat this process as needed to assign incoming call routes to additional IP Office users, as well 

as for other Avaya IP Office destinations (Hunt Group, Voicemail, Short Codes, etc.). 
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5.7. Outbound Call Routing 

For outbound call routing, a combination of system short codes and Automatic Route Selection 

(ARS) entries are used. With ARS, features like time-based routing criteria and alternate routing 

can be specified so that a call can re-route automatically if the primary route or outgoing line 

group is not available. While detailed coverage of ARS is beyond the scope of these Application 

Notes, and alternate routing was not used in the reference configuration, this section includes 

some basic screen illustrations of the ARS settings used during the compliance testing. 

5.7.1. Short Codes and Automatic Route Selection 

To create a short code to be used for ARS, right-click on Short Code, the Navigation pane and 

select New. The screen below shows the short code 9N created (note that the semi-colon is not 

used here). In this case, when the IP Office user dials 9 plus any number N, instead of being 

directed to a specific Line Group ID, the call is directed to Line Group 50: Main, which is 

configurable via ARS. 

• In the Code field, enter the dial string which will trigger this short code. In this case, 9N 

was used (note that the semi-colon is not used here). 

• Set Feature to Dial. This is the action that the short code will perform. 

• Set Telephone Number to N. The value N represents the number dialed by the user after 

removing the 9 prefix. This value is passed to ARS. 

• Set the Line Group ID to 50: Main to be directed to Line Group 50: Main, this is 

configurable via ARS. 

• For Locale, United States (US English) was used. 

• Click the OK to commit. 
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The following screen shows the example ARS configuration for the route Main. Note the 

sequence of Xs used in the Code column of the entries to specify the exact number of digits to be 

expected, following the access code and the first set of digits on the string. This type of setting 

results in a much quicker response in the delivery of the call by IP Office. 

 

To create a short code to be used for ARS, select ARS → 50: Main on the Navigation Pane and 

click Add (not shown). Configure the following parameters: 

• In the Code field, enter the dial string which will trigger this short code. In this case, 1 

followed by 10 Xs to represent the exact number of digits. 

• Set Feature to Dial. This is the action that the short code will perform. 

• Set Telephone Number to 1N. The value N represents the additional number of digits 

dialed by the user after dialing 1 (The 9 will be stripped off). 

• Set the Line Group Id to the Line Group number being used for the SIP Line, in this 

case Line Group ID 17 was used. 

• For Locale, United States (US English) was used. 

• Click OK to commit. 

 

The following example shows the dial pattern for calls within North America. 

 

 
 

Repeat the above procedure for additional dial patterns to be used by the enterprise to dial out 

from IP Office, including route patterns for calls to special numbers (411, etc.). 
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5.8. Save IP Office Primary Server Configuration 

The provisioning changes made in Avaya IP Office Manager must be applied to the Avaya IP 

Office server in order for the changes to take effect. At the top of the Avaya IP Office Manager 

page, click File → Save Configuration (if that option is grayed out, no changes are pending).  

 

A screen similar to the one below will appear, with either Merge or Reboot automatically 

selected, based on the nature of the configuration changes. The Merge option will save the 

configuration change with no impact to the current system operation. The Reboot option will 

save the configuration and cause the Avaya IP Office server to reboot.  

 

Click OK to execute the save. 
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6. Avaya IP Office Expansion System Configuration 
Navigate to File → Open Configuration (not shown), select the proper Avaya IP Office system 

from the pop-up window, and log in using the appropriate credentials. Clicking the “plus” sign 

next to IP500V2-One on the left navigation pane will expand the menu on this server. 
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6.1. Physical Hardware 

In the sample configuration, the IP500 V2 Expansion System contained a PHONE8 analog card, 

for the support of analog extensions, a DIG DCPx16 V2, for support of digital extensions. Also 

included is a VCM64 (Voice Compression Module). The VCM64 cards provide voice 

compression channels to the control unit. Voice compression channels are needed to support 

VoIP calls, including IP extensions and or IP trunks. 
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6.2. LAN Settings 

In the sample configuration, LAN1 is used to connect the Expansion System to the enterprise 

network. To view or configure the LAN1 IP address, select System on the Navigation pane. 

Select the LAN1 → LAN Settings tab on the Details pane, and enter the following:  

• IP Address: 192.168.8.165 was used in the reference configuration.  

• IP Mask: 255.255.255.0 was used in the reference configuration.  

• Click the OK button (not shown).  

 

 
 

Default values were used on the VoIP and Network Topology tabs (not shown). 
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6.3. IP Route 

To create an IP route for the Expansion system, right-click on IP Route on the left Navigation 

pane. Select New (not shown). 

• Enter 0.0.0.0 on the IP Address and IP Mask fields to make this the default route. 

• Set Gateway IP Address to the IP Address of the default router in the IP Office subnet. 

The default gateway in the reference configuration was 192.168.8.1 

• Set Destination to LAN1 from the pull-down menu. 
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6.4. IP Office Line – IP500 V2 Expansion System 

In IP Office Server Edition systems, IP Office Lines are automatically created on each server 

when a Secondary server or Expansion System is added to the solution. To edit an existing IP 

Office Line, select Line in the Navigation pane, and select the appropriate line to be configured 

in the Group pane. The screen below shows the IP Office Line to the Primary server. 

 

 



 
HG; Reviewed: 

SPOC 12/11/2023 

Avaya DevConnect Application Notes 

©2023 Avaya Inc. All Rights Reserved. 

43 of 52 

WorldNet_IPO111 

 

The screen below shows the IP Office Line, VoIP Settings tab:  

• The Codec Selection was configured using the Custom option, allowing an explicit 

order of codecs to be specified for the SIP Line. The buttons allow setting the specific 

order of preference for the codecs to be used on the SIP Line, as shown. Only codec 

G.711ULAW 64K was selected for the IP500V2 expansion systems (G.722 64K was not 

included), this was required in order for G.711 pass-through fax to work properly. 

• Select G.711 for Fax Transport Support (refer to Section 2.1). 

• Under Media Security Preferred was selected. 

• On the Advanced Media Security Options check Same As System. 
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6.5. Short Codes 

Similar to the configuration of the Primary server in Section 5.7, create a Short Code to access 

ARS. In the reference configuration, the Line Group ID is set to the ARS route illustrated in the 

next section. 
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6.6. Automatic Route Selection – ARS 

The following screen shows an example ARS configuration for the route named “To-Primary” 

on the Expansion System. The Telephone Number is set to 9N. The Line Group ID is set to 

“99999” matching the number of the Outgoing Group ID configured on the IP Office Line 17 to 

the Primary server (Section 6.4). 

 

 
 

Repeat the process described in Section 6 on any additional Secondary server or Expansion 

Systems in the solution, as required. 
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6.7. Save IP Office Expansion System Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections. 

 

The following will appear, with either Merge or Reboot selected, based on the nature of the 

configuration changes made since the last save. Note that clicking OK may cause a service 

disruption. Click OK to proceed. 
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7. WorldNet Telecommunications SIP Trunking Service 
Configuration 

To use the WorldNet Telecommunications SIP Trunking Service, a customer must request the 

service from WorldNet Telecommunications using the established sales processes. The process 

can be started by contacting WorldNet Telecommunications via the corporate web site at: 

https://www.worldnetpr.com/en/voice-service/ and requesting information. 

 

During the signup process, WorldNet Telecommunications and the customer will discuss details 

about the preferred method to be used to connect the customer’s enterprise network to WorldNet 

Telecommunications network. 

 

WorldNet Telecommunications is responsible for the configuration SIP Trunking Service. The 

customer will need to provide the public IP address used to reach Avaya IP Office at the 

enterprise, the public IP address assigned to LAN2. 

 

WorldNet Telecommunications will provide the customer the necessary information to configure 

Avaya IP Office following the steps discussed in the previous sections, including: 

 

WorldNet Telecommunications will provide the following information: 

• SIP Trunk registration credentials (User Name, Password, etc.). 

• WorldNet’s SIP Proxy IP address. 

• Supported audio codecs and their prefer order. 

• DID numbers, etc. 

https://www.worldnetpr.com/en/voice-service/
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8. Verification Steps 
This section provides verification steps that may be performed to verify that the solution is 

configured properly. 

 

The following steps may be used to verify the configuration: 

• Verify that endpoints at the enterprise site can place calls to the PSTN. 

• Verify that endpoints at the enterprise site can receive calls from the PSTN. 

• Verify that users at the PSTN can end active calls to endpoints at the enterprise by 

hanging up. 

• Verify that endpoints at the enterprise can end active calls to PSTN users by hanging up. 

8.1. IP Office System Status 

The following steps can also be used to verify the configuration. 

 

Use the IP Office System Status application to verify the state of SIP connections. Launch the 

application from Start → Programs → IP Office → System Status on the PC where IP Office 

Manager is installed, log in with the proper credentials. 
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Select the SIP line under Trunks from the left pane. On the Status tab in the right pane, verify 

the Current State is Idle for each channel. 
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8.2. Monitor 

The Avaya IP Office Monitor application can be used to monitor and troubleshoot signaling 

messaging on the SIP trunk. Launch the application from Start → Programs → IP Office → 

Monitor on the PC where IP Office Manager was installed. Click the Select Unit icon on the 

taskbar and Select the IP address of the IP Office system under verification.  

 

 
 

Clicking the Trace Options icon on the taskbar, selecting the SIP tab allows modifying the 

threshold used for capturing events, types of packets to be captured, filters, etc. Additionally, the 

color used to represent the packets in the trace can be customized by right clicking on the type of 

packet and selecting the desired color. 
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9. Conclusion 
These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) Trunking Service on an enterprise solution consisting of Avaya IP Office 11.1 to support 

WorldNet Telecommunications SIP Trunking Service. 

 

The WorldNet Telecommunications SIP Trunking Service is a SIP-based Voice over IP solution 

for customers ranging from small businesses to large enterprises. It provides a flexible, cost-

saving alternative to traditional hardwired telephony trunks.  

 

Interoperability testing was completed successfully with the observations/limitations outlined in 

the scope of testing in Section 2.1 as well as under test results in Section 2.2. 

10. Additional References  
This section references the documentation relevant to these Application Notes. Product 

documentation for Avaya IP Office, including the following, is available at: 

http://support.avaya.com/ 

 

[1] Deploying IP Office Platform Server Edition, Release 11.1 FP2, Issue 26, January 2023. 

[2] IP Office Platform 11.1.2.4, Deploying Avaya IP Office Servers as Virtual Machines, Issue 

13, January 2023. 

[3] Avaya IP Office Platform Server Edition Reference Configuration Release 11.1 FP2, Issue 

18, January 2023. 

[4]  IP Office Platform 11.1 FP2, Deploying an IP500 V2 IP Office Essential Edition System, 

Issue 39b, March 3, 2023. 

[5] Administering Avaya IP Office using Manager, Release 11.1.2.4, Issue 43, March 2023. 

[6] Avaya IP Office Platform Feature Description, Release 11.1 FP2, Issue 18, January 2023. 

 

Additional Avaya IP Office documentation can be found at: 

http://marketingtools.avaya.com/knowledgebase/ 

http://support.avaya.com/
http://marketingtools.avaya.com/knowledgebase/


 
HG; Reviewed: 

SPOC 12/11/2023 

Avaya DevConnect Application Notes 

©2023 Avaya Inc. All Rights Reserved. 

52 of 52 

WorldNet_IPO111 

 

 
 

©2023 Avaya LLC All Rights Reserved. 

Avaya and the Avaya Logo are trademarks of Avaya LLC. All trademarks identified by ® and 

™ are registered trademarks or trademarks, respectively, of Avaya LLC. All other trademarks 

are the property of their respective owners. The information provided in these Application 

Notes is subject to change without notice. The configurations, technical data, and 

recommendations provided in these Application Notes are believed to be accurate and 

dependable, but are presented without express or implied warranty. Users are responsible for 

their application of any products specified in these Application Notes. 

 

Please e-mail any questions or comments pertaining to these Application Notes along with the 

full title name and filename, located in the lower right corner, directly to the Avaya 

DevConnect Program at devconnect@avaya.com. 

 

 

mailto:devconnect@avaya.com


 
   SIPTrunk
   20231106
   enu
   
   
   CallerIDNone
   true
   0
   0
   false
   false
   true
   0
   
   SourceIP
   SystemDefault
   UpdateAuto
   SIPURI
   
   false
   false
   192.168.96.97
   SipUDP
   5060
   5060
   0.0.0.0
   0.0.0.0
   true
   
   AUTOSELECT
   false
   4
   DTMF_SUPPORT_RFC2833
   false
   true
   FOIP_G711
   false
   false
   true
   3
   UDPTL
   0
   0
   Trans_TCF
   FaxRate_14400
   2600
   2300
   true
   true
   true
   false
   false
   false
   false
   false
   false
   0
   false
   false
   false
   false
   true
   false
   false
   true
   false
   false
   false
   false
   false
   false
   false
   false
   SYSTEM
   SipPEarlyMediaSuppNone
   false
   5
   503
   0
   
   
     60
     true
  
   false
   false
   10.10.80.55
   
   
   
   
   Service Provider
   true
   
     
       
         17
         false
         
           *
           *
           525314
           SipContentCaller
           SipContentOriginalCaller
           SipContentCalled
        
         
           *
           *
           525314
           SipContentCaller
           SipContentOriginalCaller
           SipContentCalled
        
         
           *
           *
           525314
           SipContentCaller
           SipContentOriginalCaller
           SipContentCalled
        
         
         
           *
           *
           1049104
           SipContentNone
           SipContentCaller
           SipContentNone
        
         
         17
         17
         10
         10
         10
         true
         
         1
         0
         true
      
    
     false
  
   
     DISABLE
     True
     True
     True
     True
     True
     64
     1
     0
  
   SEND_LOCINFO_NEVER
   false
   false
   AllowVoicemail
   None
   false
   false


