4th September 2006 - Full PDF Text Version
This document provides details about an issue using the version 3.2.15 VoiceMail Pro client application on a non-English Operating System.
Problem:
When the VoiceMail Pro (3.2.15) client application is installed on a non-English Operating System it will open in read only mode. Upon opening the VoiceMail Pro client GUI a dialog box will present an error message in the installed language used. The error message will state that the client is running in read-only mode. This will prevent any changes being made to the VoiceMail Pro configuration.
Cause:
This issue was caused because in some instances when using a non-English Operating System the Voicemail Pro server was unable to read the version information of the Voicemail Pro GUI client due to some locale specific settings. Because the version of the client GUI could not be read the verification process failed, as a result the server would only allow a read-only connection.
Solution:
A fix for the 3.2 GA release of VoiceMail Pro (3.2.15) is available from the Avaya support website.
http://support.avaya.com
The patch is located within the IP Office 3.2 Software Download area. When unzipped the file "VMPDBSvc.exe" can be identified as version 3.2.15.2.
How to Install:
The new "VMPDBSvc.exe" executable file needs to replace the originally installed file, which if assuming a default installation path was used can be found at the following location:
c:\Program Files\Avaya\IP Office\Voicemail Pro\VM\
Ensure that the Voicemail Pro Client GUI has been closed and that all the VoiceMail services have been stopped. It is especially important ensure that you stop both the "VMProDBService" and the "Voicemail Pro Service" services.
Backup the existing "VMPDBSvc.exe" file to another directory on your computer as a precautionary measure.
Copy the new "VMPDBSvc.exe"
file into the correct Voicemail Pro installation directory so that it
replaces the originally installed file.
Assuming a default installation path was used the file would be copied
to the following location.
C:\Program Files\Avaya\IP Office\Voicemail Pro\VM\
Restart both the "VMProDBService" AND the "Voicemail Pro Service" services.
The VoiceMail Pro client application will now no longer start in read-only mode. Modifications to the VoiceMail Pro configuration can now made as normal.
The fix for this issue will be included in the next GA release of IP Office VoiceMail Pro.