版本不匹配问题

症状

数据库完整性检查失败。

启动 one-X Portal for IP Office 时,显示在登录页中的版本是以前的版本,与 Windows(开始 | 程序 | IP Office | Avaya one-X Portal for IP Office | Unistall VX.XX)菜单报告的版本不同。

原因

一般情况下,one-X Portal for IP Office 安装程序将自动停止任何与以前安装的 one-X Portal for IP Office 关联的 Tomcat Web 服务器。但是,有人发现在某些情况下,安装程序不能停止 Tomcat 服务器但是仍然报告成功完成安装过程。这导致组件之间的版本不一致。

解决方法

1. 卸载 one-X Portal for IP Office

2. 手动删除 one-X Portal for IP Office 应用程序文件夹(默认情况下为 C:\Program Files (x86)\Avaya\onexportal)。如果系统报告文件夹被锁定,则需要重新启动服务器。

3. 安装新版本的 one-X Portal for IP Office。

one-X Portal for IP Office 不启动

症状

one-X Portal for IP Office 不能启动。

Prorun Error(运行前错误)出现在 Tomcat 服务器日志文件中。

其它 Java 应用程序不能在服务器上运行(例如 IP Office System Status Application)。

解决方法

1. 检查是否存在端口冲突。如存在,则需移除该冲突应用程序,或使用不同的端口安装 one-X Portal for IP Office。

2. 使用 Windows 添加或删除程序 applet 删除 Java。

3. 卸载 one-X Portal for IP Office

4. 安装 one-X Portal for IP Office。