Problema de incompatibilidad de versiones

Síntomas

No se puede realizar el control de la integridad de base de datos.

Al iniciar one-X Portal para IP Office, la versión que aparece en la página de inicio de sesión es la versión anterior y no coincide con la que aparece en el menú de Windows (Inicio| Programas | IP Office | Avaya one-X Portal for IP Office | Desinstalar VX.XX).

Causa

Habitualmente, el instalador de one-X Portal para IP Office detendrá automáticamente cualquier servidor Web Tomcat relacionado con una instalación anterior de one-X Portal para IP Office. Sin embargo, se observó que en algunos casos no puede detener el servidor Tomcat y de todas formas indica que el proceso de instalación finalizó con éxito. Esto da lugar a una incompatibilidad de versiones entre los componentes.

Solución

1. Quitar one-X Portal para IP Office.

2. Elimine manualmente la carpeta de la aplicación one-X Portal para IP Office (de forma predeterminada C:\Program Files (x86)\Avaya\onexportal). Si se informa que la carpeta está bloqueada, debe reiniciar el servidor.

3. Instale la nueva versión de one-X Portal para IP Office.

one-X Portal para IP Office no se inicia

Síntomas

one-X Portal para IP Office no se inicia.

El mensaje Prorun Error (Error de prorun) aparece en los archivos de registro del servidor Tomcat.

Otras aplicaciones Java no se ejecutan en el servidor (por ejemplo, IP Office System Status Application).

Solución

1. Verifique si hay un conflicto de puertos. Si existe alguno, quite la otra aplicación o instale one-X Portal para IP Office utilizando un puerto diferente.

2. Elimine Java por medio de la aplicación Agregar o quitar programas de Windows.

3. Quitar one-X Portal para IP Office.

4. Instalar one-X Portal para IP Office.