Несоответствие версий

Признаки

Целостность базы данных не подтверждается.

После запуска one-X Portal for IP Office на странице входа отображается номер устаревшей версии, который отличается от номера, сообщаемого операционной системой Windows (меню Пуск | Программы | IP Office | Avaya one-X Portal for IP Office | Удалить VX.XX).

Причина

Обычно программа установки one-X Portal for IP Office автоматически останавливает работу любого веб-сервера Tomcat, связанного с предыдущей установкой one-X Portal for IP Office. Однако оказалось, что в некоторых случаях сервер Tomcat не останавливается, хотя программа сообщает об успешном завершении процесса установки. Это приводит к несоответствию версий разных компонентов.

Способ устранения

1. Удалите one-X Portal for IP Office.

2. Вручную удалите папку приложения one-X Portal for IP Office (по умолчанию это C:\Program Files (x86)\Avaya\onexportal). Если система сообщает, что папка заблокирована, следует перезагрузить сервер.

3. Установите новую версию one-X Portal for IP Office.

one-X Portal for IP Office не запускается

Признаки

Не удается запустить one-X Portal for IP Office.

В журнале сервера Tomcat появляется ошибка Prorun Error.

На сервере не могут выполняться другие приложения Java (например, IP Office System Status Application).

Способ устранения

1. Проверьте, нет ли конфликта портов. Если он существует, удалите другое приложение или установите one-X Portal for IP Office, используя другой порт.

2. С помощью компонента Windows Установка и удаление программ удалите Java.

3. Удалите one-X Portal for IP Office.

4. Установите one-X Portal for IP Office.